Zcash4win BETA is out!


#22

All sounds good and working fine for me. thank you @radix42


#23

my internet connection sucks sometimes, so took me a long time (about 2 hours) to download the proving key. Otherwise it worked great! and I did not get any "Unknown publisher" warnings. Maybe my user control settings are set to low or off, not sure why I did not get those warnings.

Such a simple installation, I hope that ZECC gave you a hefty donation for your completed work.


#24

yeah you must have your stuff dialed way down, with the defaults on win2k16 server it whines something horrible because its not signed, both to download it and to install. I'll be getting a code signing certificate in the next couple of days and that pain should all go away.


#25

I dont like getting pop up warnings when i test out stuff or install stuff... though I should probably turn it up when im not doing a video and turn it down before I do a video.


#26

that sounds like a wise course of action!


#27

heh, i only use windows on this computer to do videos though :stuck_out_tongue: so LOL i guess it would be turned down like 99% of the time... I use Linux/Arch/Manjaro on this computer 99% of the time... I game on my desktop... this is a kickass 4930m CPU laptop with SLI gtx780m's... GPUs are a bit old... but heh.. no need to upgrade as i use desktops to game now... used to not have desktops as was always renting and moving around... bit more settled now.


#28

I do all my Windows dev and testing in VMs, either on my linux machine, or AWS or Azure


#29

yeah I only used a Vm when trying to create hackintosh USB installers LOL
I dont really like VMs... though I guess for this kind of installation I could use one...
but for video editing,. better use the full resources so better to just do it directly in windows

this laptop i triple boot win10/linux mint/linux arch manjaro... and mint is just there for a back up... windows is just there for video editing - and IF i ever take the laptop out of the house - to play a video game...


#30

@ anybody who's installed this: how big is the install including blockchain? Can it be installed in a directory other than os? I keep a small os for easy bu and restore. Thanks.

BTW, thanks Radix42 for making this!!!!


#31

The current blockchain is a bit over 1.5 GB, and zcash4win is 206 MB. You can have the blockchain files in a different location than the default %AppData%\Zcash\ if you move them while its stopped, but then you have to start zcashd.exe by hand in the command line before the GUI with the -datadir= option with the location where you moved that directory to.


#32

Thanks for this. I'll give it a try. Can I direct the blockchain to another drive before it installs to the default location? Thanks.


#33

to do that you'll have to create the Zcash folder and zcash.conf file by hand and start zcashd.exe manually in powershell before you launch zcash4win the first time, but yes you theoretically can do that.


#34

Have installed it and all works fine. Is there somewhere to provide feedback? For example, after install ask "Do you want to run zcash4win now?" - rather than having to find it in the start menu? When I installed, it didn't give any confirmation at the end of install - just looked like is disappeared..


#35

I'm still working on customizing the installation setup.....yes this is why
its a BETA...and this is the right place for feedback! :slight_smile:


#36

Hi, While installing it start verifying the proving key and then I get a critical error. " A general unexpected critical error has occured: com.eclipseource.json ParseException: Expected value at 1:1 See console output for more detailed error information". I'm running windows 10. Very happy we now have a zcash windows just would like to get it working.

Regards,
jc


#37

hhmmmmm....sometimes that happens when zcashd is starting up, its supposed to catch that error, but there's a race condition I haven't been able to figure out....that one's not a Windows specific problem, been trying to track down what triggers it for months.

Try starting zcashd.exe by hand in a Powershell window before launching the gui with these commands and see if that works:

cd c:\Program Files\zcash4win\app
.\zcashd.exe

#38

I am getting this:

Set-Location : A positional parameter cannot be found that accepts argument 'Files\zcash4win\app'.
At line:1 char:1
+ cd c:\Program Files\zcash4win\app
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : InvalidArgument: (:slight_smile: [Set-Location], ParameterBindingException
+ FullyQualifiedErrorId : PositionalParameterNotFound,Microsoft.PowerShell.Commands.SetLocationCommand

.\zcashd.exe : The term '.\zcashd.exe' is not recognized as the name of a cmdlet, function, script file, or operable
program. Check the spelling of the name, or if a path was included, verify that the path is correct and try again.
At line:2 char:1
+ .\zcashd.exe
+ ~~~~~~~~~~~~
+ CategoryInfo : ObjectNotFound: (.\zcashd.exe:String) [], CommandNotFoundException
+ FullyQualifiedErrorId : CommandNotFoundException

Any thoughts


#39

ack I think you need quotes! Try:

cd "c:\Program Files\zcash4win\app"
.\zcashd.exe -daemon=0 -showmetrics=1

#40

ok that was better....

Before starting zcashd, you need to create a configuration file:
C:\Users\Jeffrey Chudyk\AppData\Roaming\Zcash\zcash.conf
It can be completely empty! That indicates you are happy with the default
configuration of zcashd. But requiring a configuration file to start ensures
that zcashd won't accidentally compromise your privacy if there was a default
option you needed to change.

You can look at the example configuration file for suggestions of default
options that you may want to change. It should be in one of these locations,
depending on how you installed Zcash:
- Source code: contrib/DEBIAN/examples/zcash.conf
- .deb package: /usr/share/doc/zcash/examples/zcash.conf
PS C:\Program Files\zcash4win\app>

What must I do next?

Thanks for your quick help...I really appreciate it.

jc


#41

Ugh the gui makes the config file on first launch!

Try this:

cd "c:\Program Files\zcash4win\app"
.\first-run.bat
.\zcashd.exe

And then once zcashd.exe is running ok, try launching the GUI